이전글 다음글 목록
[MS 보안업데이트]2012년 2월 MS 정기 보안업데이트 권고
  • 글쓴이 : (주)넷팜
  • 날짜 : 2012-02-16 09:18:29
  • 조회 : 3605

[MS12-008] Windows 커널 모드 드라이버에서 발생하는 취약점으로 인한 원격코드 실행 문제

□ 영향

o 공격자가 영향 받는 시스템에 대해 완전한 권한 획득


□ 설명

o 사용자가 특수하게 제작된 콘텐츠를 포함된 웹사이트를 열람하거나, 특수하게 조작된 응용프로그램이 로컬에서 실행되고 있을 경우, 원격코드가 실행될 수 있는 취약점이 존재

o 관련취약점 :

- GDI 액세스 위반 취약점(CVE-2011-5046)
- 키보드 레이아웃 해제 후 사용 취약점(CVE-2012-0154)

o 영향 : 원격코드실행

o 중요도 : 긴급


□ 해당시스템

o 영향 받는 소프트웨어

- Windows XP 서비스 팩3
- Windows XP Professional 64-bit 서비스 팩2
- Windows Server 2003 서비스 팩2
- Windows Server 2003 64-bit 서비스 팩2
- Windows Server 2003 Itanium 서비스 팩2
- Windows Vista 서비스 팩2
- Windows Vista 64-bit 서비스 팩2
- Windows Server 2008 서비스 팩2
- Windows Server 2008 64-bit 서비스 팩2
- Windows Server 2008 Itanium 서비스 팩2
- Windows 7 서비스 팩0, 1
- Windows 7 64-bit 서비스 팩0, 1
- Windows Server 2008 R2 64-bit 서비스 팩0, 1
- Windows Server 2008 R2 Itanium 서비스 팩0, 1


□ 해결책

o 해당 시스템에 대한 마이크로소프트사의 취약점 패치 적용


□ 참조사이트

o 영문 : http://technet.microsoft.com/en-us/security/bulletin/MS12-008
o 한글 : http://technet.microsoft.com/ko-kr/security/bulletin/MS12-008



[MS12-009] Ancillary Function Driver에서 발생하는 취약점으로 인한 권한상승 문제

□ 영향

o 공격자가 영향 받는 시스템에 대해 권한상승


□ 설명

o 시스템에 로그인된 공격자가 특수하게 제작된 프로그램을 실행할 경우, 권한상승이 될 수 있는 취약점 존재

o 관련취약점 :

- AfdPoll 권한 상승 취약점(CVE-2012-0148)
- Ancillary Function Driver 권한 상승 취약점(CVE-2012-0149)

o 영향 : 권한상승

o 중요도 : 중요


□ 해당시스템

o 영향 받는 소프트웨어

- Windows XP Professional 64-bit 서비스 팩2
- Windows Server 2003 서비스 팩2
- Windows Server 2003 64-bit 서비스 팩2
- Windows Server 2003 Itanium 서비스 팩2
- Windows Vista 64-bit 서비스 팩2
- Windows Server 2008 64-bit 서비스 팩2
- Windows Server 2008 Itanium 서비스 팩2
- Windows 7 64-bit 서비스 팩0, 1
- Windows Server 2008 R2 64-bit 서비스 팩0, 1
- Windows Server 2008 R2 Itanium 서비스 팩0, 1

o 영향 받지 않는 소프트웨어

- Windows XP 서비스 팩3
- Windows Vista 서비스 팩2
- Windows Server 2008 서비스 팩2
- Windows 7 서비스 팩0, 1


□ 해결책

o 해당 시스템에 대한 마이크로소프트사의 취약점 패치 적용


□ 참조사이트

o 영문 : http://technet.microsoft.com/en-us/security/bulletin/MS12-009
o 한글 : http://technet.microsoft.com/ko-kr/security/bulletin/MS12-009



[MS12-010] Internet Explorer 누적 보안 업데이트

□ 영향

o 공격자가 영향 받는 시스템에 대해 완전한 권한 획득


□ 설명

o 사용자가 Internet Explorer를 사용하여 특수하게 조작된 웹페이지를 열람할 경우, 원격코드가 실행될 수 있는 취약점이 존재

o 관련취약점 :

- 복사 및 붙여넣기 정보 유출 취약점(CVE-2012-0010)
- HTML 레이아웃 원격 코드 실행 취약점(CVE-2012-0011)
- 널 바이트 정보 유출 취약점(CVE-2012-0012)
- VML 원격 코드 실행 취약점(CVE-2012-0155)

o 영향 : 원격코드실행

o 중요도 : 긴급


□ 해당시스템

o 영향 받는 소프트웨어

Windows XP 서비스 팩3
Internet Explorer 6
Internet Explorer 7
Internet Explorer 8

Windows XP Professional 64-bit 서비스 팩2
Internet Explorer 6
Internet Explorer 7
Internet Explorer 8

Windows Server 2003 서비스 팩2
Internet Explorer 6
Internet Explorer 7
Internet Explorer 8

Windows Server 2003 64-bit 서비스 팩2
Internet Explorer 6
Internet Explorer 7
Internet Explorer 8

Windows Server 2003 Itanium 서비스 팩2
Internet Explorer 6
Internet Explorer 7
Internet Explorer 8

Windows Vista 서비스 팩2
Internet Explorer 7
Internet Explorer 8
Internet Explorer 9

Windows Vista 64-bit 서비스 팩2
Internet Explorer 7
Internet Explorer 8
Internet Explorer 9

Windows Server 2008 서비스 팩2**
Internet Explorer 7
Internet Explorer 8
Internet Explorer 9

Windows Server 2008 64-bit 서비스 팩2**
Internet Explorer 7
Internet Explorer 8
Internet Explorer 9

Windows Server 2008 Itanium 서비스 팩2
Internet Explorer 7

Windows 7 서비스 팩0, 1
Internet Explorer 8
Internet Explorer 9

Windows 7 64-bit 서비스 팩0, 1
Internet Explorer 8
Internet Explorer 9

Windows Server 2008 R2 64-bit 서비스 팩0, 1**
Internet Explorer 8
Internet Explorer 9

Windows Server 2008 R2 Itanium 서비스 팩0, 1**
Internet Explorer 8

※ **표시된 윈도우를 서버코어(Server Core)옵션으로 설치한 경우, 해당 취약점에 영향을 받지 않음


□ 해결책

o 해당 시스템에 대한 마이크로소프트사의 취약점 패치 적용


□ 참조사이트

o 영문 : http://technet.microsoft.com/en-us/security/bulletin/MS12-010
o 한글 : http://technet.microsoft.com/ko-kr/security/bulletin/MS12-010



[MS12-011] Microsoft SharePoint에서 발생하는 취약점으로 인한 권한상승 문제

□ 영향

o 공격자가 영향 받는 시스템에 대해 권한상승


□ 설명

o 사용자가 특수하게 조작된 URL을 클릭할 경우, 권한상승이 될 수 있는 취약점 존재

o 관련취약점 :

- inplview.aspx의 XSS 취약점(CVE-2012-0017)
- themeweb.aspx의 XSS 취약점(CVE-2012-0144)
- wizardlist.aspx의 XSS 취약점(CVE-2012-0145)

o 영향 : 권한상승

o 중요도 : 중요


□ 해당시스템

o 영향 받는 소프트웨어

- Microsoft SharePoint Server 2010 서비스 팩 0, 1
- Microsoft SharePoint Foundation 2010 서비스 팩 0, 1

o 영향 받지 않는 소프트웨어

- Microsoft Office Groove 2007 서비스 팩 2
- Microsoft SharePoint Workspace 2010 서비스 팩 0, 1
- Microsoft SharePoint Workspace 2010 64-bit 서비스 팩 0, 1
- Microsoft Office SharePoint Portal Server 2003 서비스 팩 3
- Microsoft Office Forms Server 2007 서비스 팩 2, 3
- Microsoft Office Forms Server 2007 64-bit 서비스 팩 2, 3
- Microsoft Office Groove Data Bridge Server 2007 서비스 팩 2, 3
- Microsoft Office Groove Data Bridge Server 2007 64-bit 서비스 팩 2, 3
- Microsoft Groove Server 2010서비스 팩 0, 1
- Microsoft Windows SharePoint Services 2.0
- Microsoft Windows SharePoint Services 3.0 서비스 팩 2, 3
- Microsoft Windows SharePoint Services 3.0 64-bit 서비스 팩 2, 3


□ 해결책

o 해당 시스템에 대한 마이크로소프트사의 취약점 패치 적용


□ 참조사이트

o 영문 : http://technet.microsoft.com/en-us/security/bulletin/MS12-011
o 한글 : http://technet.microsoft.com/ko-kr/security/bulletin/MS12-011



[MS12-012] Color Control Panel에서 발생하는 취약점으로 인한 원격코드 실행 문제

□ 영향

o 공격자가 영향 받는 시스템에 대해 완전한 권한 획득


□ 설명

o 사용자가 특수하게 조작된 DLL파일과 동일한 디렉토리 경로에 존재하는 정상적인 .icm 및 .icc 파일을 열람할 경우, 원격코드가 실행될 수 있는 취약점이 존재

o 관련취약점 :

- Color Control Panel의 안전하지 않은 라이브러리 로드 취약점(CVE-2010-5082)

o 영향 : 원격코드실행

o 중요도 : 중요


□ 해당시스템

o 영향 받는 소프트웨어

- Windows Server 2008 서비스 팩2**
- Windows Server 2008 64-bit 서비스 팩2**
- Windows Server 2008 Itanium 서비스 팩2
- Windows Server 2008 R2 64-bit 서비스 팩0, 1**
- Windows Server 2008 R2 Itanium 서비스 팩0, 1

o 영향 받지 않는 소프트웨어

- Windows XP 서비스 팩3
- Windows XP Professional 64-bit 서비스 팩2
- Windows Server 2003 서비스 팩2
- Windows Server 2003 64-bit 서비스 팩2
- Windows Server 2003 Itanium 서비스 팩2
- Windows Vista 서비스 팩2
- Windows Vista 64-bit 서비스 팩2
- Windows 7 서비스 팩0, 1
- Windows 7 64-bit 서비스 팩0, 1

※ **표시된 윈도우를 서버코어(Server Core)옵션으로 설치한 경우, 해당 취약점에 영향을 받지 않음


□ 해결책

o 해당 시스템에 대한 마이크로소프트사의 취약점 패치 적용


□ 참조사이트

o 영문 : http://technet.microsoft.com/en-us/security/bulletin/MS12-012
o 한글 : http://technet.microsoft.com/ko-kr/security/bulletin/MS12-012



[MS12-013] C 런타임 라이브러리에서 발생하는 취약점으로 인한 원격코드 실행 문제

□ 영향

o 공격자가 영향 받는 시스템에 대해 완전한 권한 획득


□ 설명

o 사용자가 특수하게 조작된 미디어 파일을 열람할 경우, 원격코드가 실행될 수 있는 취약점이 존재

o 관련취약점 :

- Msvcrt.dll 버퍼 오버플로 취약점(CVE-2012-0150)

o 영향 : 원격코드실행

o 중요도 : 긴급


□ 해당시스템

o 영향 받는 소프트웨어

- Windows Vista 서비스 팩2
- Windows Vista 64-bit 서비스 팩2
- Windows Server 2008 서비스 팩2
- Windows Server 2008 64-bit 서비스 팩2
- Windows Server 2008 Itanium 서비스 팩2
- Windows 7 서비스 팩0, 1
- Windows 7 64-bit 서비스 팩0, 1
- Windows Server 2008 R2 64-bit 서비스 팩0, 1
- Windows Server 2008 R2 Itanium 서비스 팩0, 1

o 영향 받지 않는 소프트웨어

- Windows XP 서비스 팩3
- Windows XP Professional 64-bit 서비스 팩2
- Windows Server 2003 서비스 팩2
- Windows Server 2003 64-bit 서비스 팩2
- Windows Server 2003 Itanium 서비스 팩2


□ 해결책

o 해당 시스템에 대한 마이크로소프트사의 취약점 패치 적용


□ 참조사이트

o 영문 : http://technet.microsoft.com/en-us/security/bulletin/MS12-013
o 한글 : http://technet.microsoft.com/ko-kr/security/bulletin/MS12-013



[MS12-014] Indeo 코덱에서 발생하는 취약점으로 인한 원격코드 실행 문제

□ 영향

o 공격자가 영향 받는 시스템에 대해 완전한 권한 획득


□ 설명

o 사용자가 특수하게 조작된 DLL파일과 동일한 디렉토리 경로에 존재하는 정상적 AVI을 열람할 경우, 원격코드가 실행될 수 있는 취약점이 존재

o 관련취약점 :

- Indeo 코덱의 안전하지 않은 라이브러리 로드 취약점(CVE-2010-3138)

o 영향 : 원격코드실행

o 중요도 : 중요


□ 해당시스템

o 영향 받는 소프트웨어

- Windows XP 서비스 팩3

o 영향 받지 않는 소프트웨어

- Windows XP Professional 64-bit 서비스 팩2
- Windows Server 2008 서비스 팩2
- Windows Server 2008 64-bit 서비스 팩2
- Windows Server 2008 Itanium 서비스 팩2
- Windows Vista 서비스 팩2
- Windows Vista 64-bit 서비스 팩2
- Windows 7 서비스 팩0, 1
- Windows 7 64-bit 서비스 팩0, 1
- Windows Server 2008 R2 64-bit 서비스 팩0, 1
- Windows Server 2008 R2 Itanium 서비스 팩0, 1
- Windows Server 2003 서비스 팩2
- Windows Server 2003 64-bit 서비스 팩2
- Windows Server 2003 Itanium 서비스 팩2


□ 해결책

o 해당 시스템에 대한 마이크로소프트사의 취약점 패치 적용


□ 참조사이트

o 영문 : http://technet.microsoft.com/en-us/security/bulletin/MS12-014
o 한글 : http://technet.microsoft.com/ko-kr/security/bulletin/MS12-014



[MS12-015] Visio Viewer 2010 에서 발생하는 취약점으로 인한 원격코드 실행 문제

□ 영향

o 공격자가 영향 받는 시스템에 대해 완전한 권한 획득


□ 설명

o 사용자가 특수하게 조작된 Visio 파일을 열람할 경우, 원격코드가 실행될 수 있는 취약점이 존재

o 관련취약점 :

- VSD 파일 형식 레코드 메모리 손상 취약점(CVE-2012-0019)
- VSD 파일 형식 레코드 메모리 손상 취약점(CVE-2012-0020)
- VSD 파일 형식 레코드 메모리 손상 취약점(CVE-2012-0136)
- VSD 파일 형식 레코드 메모리 손상 취약점(CVE-2012-0137)
- VSD 파일 형식 레코드 메모리 손상 취약점(CVE-2012-0138)

o 영향 : 원격코드실행

o 중요도 : 중요


□ 해당시스템

o 영향 받는 소프트웨어

- Microsoft Visio Viewer 2010 서비스 팩 0, 1
- Microsoft Visio Viewer 2010 64-bit 서비스 팩 0, 1

o 영향 받지 않는 소프트웨어

- Microsoft Visio 2003 서비스 팩 3
- Microsoft Visio 2007 서비스 팩 2, 3
- Microsoft Visio 2010 서비스 팩 1, 2
- Microsoft Visio 2010 64-bit 서비스 팩 1, 2


□ 해결책

o 해당 시스템에 대한 마이크로소프트사의 취약점 패치 적용


□ 참조사이트

o 영문 : http://technet.microsoft.com/en-us/security/bulletin/MS12-015
o 한글 : http://technet.microsoft.com/ko-kr/security/bulletin/MS12-015


[MS12-016] .NET Framework 및 Microsoft Silverlight에서 발생하는 취약점으로 인한 원격코드 실행 문제

□ 영향

o 공격자가 영향 받는 시스템에 대해 완전한 권한 획득


□ 설명

o 사용자가 XBAP(XAML 브라우저 응용 프로그램) 또는 Silverlight 응용 프로그램을 실행할 수 있는 웹브라우저를 사용하여 특수하게 조작된 웹페이지를 열람할 경우, 원격코드가 실행될 수 있는 취약점이 존재

o 관련취약점 :

- .NET Framework 비관리 개체 취약점(CVE-2012-0014)
- .NET Framework 힙 손상 취약점(CVE-2012-0015)

o 영향 : 원격코드실행

o 중요도 : 긴급


□ 해당시스템

o 영향 받는 소프트웨어


Microsoft .NET Framework 2.0 서비스 팩 2
Windows XP 서비스 팩3
Windows XP Professional 64-bit 서비스 팩2
Windows Server 2003 서비스 팩2
Windows Server 2003 64-bit 서비스 팩2
Windows Server 2003 Itanium 서비스 팩2
Windows Vista 서비스 팩2
Windows Vista 64-bit 서비스 팩2
Windows Server 2008 서비스 팩2
Windows Server 2008 64-bit 서비스 팩2
Windows Server 2008 Itanium 서비스 팩2

Microsoft .NET Framework 3.5.1
Windows 7 서비스 팩0, 1
Windows 7 64-bit 서비스 팩0, 1
Windows Server 2008 R2 64-bit 서비스 팩0, 1
Windows Server 2008 R2 Itanium 서비스 팩0, 1

Microsoft .NET Framework 4
Windows XP 서비스 팩3
Windows XP Professional 64-bit 서비스 팩2
Windows Server 2003 서비스 팩2
Windows Server 2003 64-bit 서비스 팩2
Windows Server 2003 Itanium 서비스 팩2
Windows Vista 서비스 팩2
Windows Vista 64-bit 서비스 팩2
Windows Server 2008 서비스 팩2
Windows Server 2008 64-bit 서비스 팩2
Windows Server 2008 Itanium 서비스 팩2
Windows 7 서비스 팩0, 1
Windows 7 64-bit 서비스 팩0, 1
Windows Server 2008 R2 64-bit 서비스 팩0, 1
Windows Server 2008 R2 Itanium 서비스 팩0, 1


o 영향 받지 않는 소프트웨어

- Microsoft .NET Framework 1.1 서비스 팩 1

- Microsoft .NET Framework 3.5 서비스 팩 1

- Mac에 설치된 Microsoft Silverlight 5

- 모든 Microsoft Windows 클라이언트 릴리스에 설치된 Microsoft Silverlight 5

- 모든 Microsoft Windows 서버 릴리스에 설치된 Microsoft Silverlight 5




□ 해결책

o 해당 시스템에 대한 마이크로소프트사의 취약점 패치 적용




□ 참조사이트

o 영문 : http://technet.microsoft.com/en-us/security/bulletin/MS12-016

o 한글 : http://technet.microsoft.com/ko-kr/security/bulletin/MS12-016