이전글 다음글 목록
[MS 보안업데이트]2009년 1월 MS 정기 보안업데이트 권고
  • 글쓴이 : (주)넷팜
  • 날짜 : 2009-01-14 09:40:00
  • 조회 : 4356

MS 윈도우의 SMB 서비스에서 해킹에 악용 가능한 취약점에 대해
1월 MS 정기보안업데이트가 발표되었으니, 조속히 보안패치하시기 바랍니다.

[MS09-001] SMB 취약점으로 인한 원격코드실행 문제

□ 영향
o 공격자가 영향 받는 시스템에 대해 완전한 권한 획득

□ 설명
o 사용자 시스템에서 공격자가 전송한 조작된 SMB 패킷을 처리하는 과정에서 원격코드 실행
취약점 존재
※ SMB : Server Message Block, 도스나 윈도우에서 파일이나 디렉토리 및 주변장치들을
공유하는데 사용되는 메시지 형식
o 취약점 공격 시 인증이 필요하지 않아 공격자는 서버 서비스가 동작중인 컴퓨터에 조작된
네트워크 메시지를 전송. 공격이 성공하면 공격자는 프로그램 설치, 삭제, 계정 생성 등
영향 받는 시스템에 대해 완전한 권한 획득 가능
o 관련취약점 :
- SMB Buffer Overflow Remote Code Execution Vulnerability - CVE-2008-4834
- SMB Validation Remote Code Execution Vulnerability - CVE-2008-4835
- SMB Validation Denial of Service Vulnerability - CVE-2008-4114
o 영향 : 원격코드실행
o 중요도 : 긴급

□ 해당시스템
o 영향 받는 소프트웨어
- Microsoft Windows 2000 SP4
- Microsoft Windows XP SP2, SP3
- Microsoft Windows XP Professional x64, SP2
- Microsoft Windows Server 2003 SP1, SP2
- Microsoft Windows Server 2003 x64, SP2
- Microsoft Windows Server 2003 for Itanium-based Systems SP1, SP2
- Microsoft Windows Vista, SP1
- Microsoft Windows Vista x64, SP1
- Microsoft Windows Server 2008 32-bit, x64, Itanium-based Systems

□ 해결책
o 해당 시스템에 대한 마이크로소프트사의 취약점 패치 적용

□ 참조사이트
o 영문 : http://www.microsoft.com/technet/security/Bulletin/MS09-001.mspx
o 한글 : http://www.microsoft.com/korea/technet/security/bulletin/MS09-001.mspx